1547 résultats trouvés

par m3ellem1
Aujourd’hui, 12:25
Forum : Excel - VBA
Sujet : Enregistrement des données dans tableau
Réponses : 4
Vues : 29

Re: Enregistrement des données dans tableau

je comprend plus rien :oops:
je laisse la main aux autres collègues!
Bonne journée
par m3ellem1
Aujourd’hui, 11:42
Forum : Excel - VBA
Sujet : Enregistrement des données dans tableau
Réponses : 4
Vues : 29

Re: Enregistrement des données dans tableau

Salut Guithou51, un essai Private Sub CommandButton1_Click() 'Enregistrer le formulaire sur une feuille différente avec condition, le 29/02/2020 par Guillaume 'Modifier les données du formulaire qui comporte le même numéro Dim ligne As Long Dim Cel As Range Dim ws As Worksheet Set ws = Worksheets("c...
par m3ellem1
Aujourd’hui, 00:54
Forum : Excel - VBA
Sujet : Fonction avec " " intégré dans une macro
Réponses : 2
Vues : 32

Re: Fonction avec " " intégré dans une macro

Salut Sylvain,

à tester
ActiveWorkbook.Names.Add Name:="Plage_dynamique_essais", RefersToR1C1:= _
"=OFFSET('Base commande'!R2C36,,,COUNTIF('Base commande'!C36,""?*"")-1)"
Bonne nuit
par m3ellem1
Hier, 12:40
Forum : Excel - VBA
Sujet : Sommes de lignes identiques
Réponses : 3
Vues : 34

Re: Sommes de lignes identiques

Salut tout le monde,

formule en G2 et tirer vers le bas
=SOMME.SI.ENS(D:D;C:C;F2;B:B;B:B)
bonne journée
par m3ellem1
Hier, 11:56
Forum : Excel - VBA
Sujet : Incrémentation avec cellule venant de plusieurs feuilles
Réponses : 2
Vues : 29

Re: Incrémentation avec cellule venant de plusieurs feuilles

Salut Berthyone,

à tester
=SI(C7="";"";SI(INDIRECT("'"&LIGNE(A1)&"'!G$8")="oui";"";SI(D7="SO";"";SI(D7="PM";"";INDIRECT("'"&LIGNE(A1)&"'!L$9")))))
Sinon avec une seule condition SI
=SI(OU(C7="";D7="PM";INDIRECT("'"&LIGNE(A1)&"'!G$8")="oui";D7="SO");"";INDIRECT("'"&LIGNE(A1)&"'!L$9"))
@++
par m3ellem1
Hier, 10:37
Forum : Excel - VBA
Sujet : Formule conditionnelle
Réponses : 2
Vues : 26

Re: Formule conditionnelle

Salut Blandine,

formule dans C1
=SI(B1="";"";A1+B1)
@++
par m3ellem1
Hier, 10:32
Forum : Excel - VBA
Sujet : Somme si ens avec la plage variante.
Réponses : 5
Vues : 43

Re: Somme si ens avec la plage variante.

Bonjour tout le monde,

une autre formule matricielle en C4 à confirmer avec Ctrl+Maj+Entrée
=SOMME(SI(($C$28:$C$38=A4)*($D$28:$D$38=C$3)*($E$27:$P$27=$C$2);$E$28:$P$38;0))
Bonne journée
par m3ellem1
Hier, 09:47
Forum : Excel - VBA
Sujet : Valeur si conditions
Réponses : 2
Vues : 21

Re: Valeur si conditions

Bonjour JBPele,

à tester
=INDEX($AB$3:$AB$219;EQUIV("*"&A3&"-"&E3&"*";$Z$3:$Z$219;0))
@++
par m3ellem1
Hier, 00:53
Forum : Excel - VBA
Sujet : RechercheV et liste déroulante
Réponses : 11
Vues : 124

Re: RechercheV et liste déroulante

Salut tout le monde,

voici une proposition avec plage dynamique et formules (pas besoin du bouton AJOUTEZ L'ARTICLE)
ExempleExcel1_v1.xlsm
(31.2 Kio) Téléchargé 3 fois
Pour les images voir ici http://boisgontierjacques.free.fr/pages ... erchev.htm

bonne nuit
par m3ellem1
Hier, 00:27
Forum : Excel - VBA
Sujet : Attribution de valeurs à des cellules en chaîne
Réponses : 4
Vues : 59

Re: Attribution de valeurs à des cellules en chaîne

Salut tout le monde,

un essai avec une formule matricielle
=SI(C2="";"";INDEX($A$2:$A$4;MIN(SI(SOMME(($C$2:C2))>$B$2:$B$4;"";LIGNE($1:$3)))))
Exemple_V2.xlsx
(10.52 Kio) Téléchargé 2 fois
Bonne nuit