1416 résultats trouvés

par Andre13
8 avril 2019, 20:37
Forum : Excel - VBA
Sujet : Enlever 1 heure à une celle qui contient DATE + HEURE
Réponses : 8
Vues : 80

Re: Enlever 1 heure à une celle qui contient DATE + HEURE

Bonjour toutes et tous
Edit : coucou à tous ;;) ;;) ;;)
@ tester :
en B2 la date + heure (format personnalisé jj/mm/aaaa hh:mm)
en C2 Formule ci-dessous:
=B2-"01:00"
crdlt,
André
par Andre13
7 avril 2019, 19:12
Forum : Excel - VBA
Sujet : Excel menu déroulant avec plusieurs mots
Réponses : 3
Vues : 41

Re: Excel menu déroulant avec plusieurs mots

re-Bonjour
Exact, les mots séparés on ne peut pas c'est pour cela qu'il y a==> _

en images, on ne peut pas modifier des mots séparés
par Andre13
7 avril 2019, 15:49
Forum : Excel - VBA
Sujet : Excel menu déroulant avec plusieurs mots
Réponses : 3
Vues : 41

Re: Excel menu déroulant avec plusieurs mots

Bonjour toutes et tous 1/Sélectionné B2 à B20 de ton onglet: Risques présents sur le site puis, CTRL+ C pour copier 2/ ouvrir le bloc note : puis CTRL+V pour coller 3/ toujours dans le bloc note menu Edition choisir dan la liste Remplacer Dans la zone de texte :Rechercher mettre _ dans Remplacer par...
par Andre13
1 avril 2019, 21:31
Forum : Excel - VBA
Sujet : Zoom évolutif sur certains onglets
Réponses : 18
Vues : 148

Re: Zoom évolutif sur certains onglets

Bonjour toutes et tous coucou Xorsankukai je ne sais pas si cela est correct à l'ouverture d'un classeur comme ceci :oops: en prenant le code de Xorsunkukai @ tester avec demande d'une boîte à message Private Sub Workbook_Open() On Error Goto plouf If MsgBox("Etes-vous certain de vouloir zoomer à 85...
par Andre13
31 mars 2019, 15:21
Forum : Excel - VBA
Sujet : Configuration date
Réponses : 5
Vues : 35

Re: Configuration date

Bonjour toutes et tous, @tester coucou Ric ;;) 1/ Voir dans les Options d'Excel le menu de gauche choisir 'Options avancées' puis à droite rechercher 'Lors du Calcul de ce classeur' en dessous voir si, la case est décochée 'Utiliser le calendrier 1904' 2/ Si la colonne N, il n'y a rien dans le table...
par Andre13
27 mars 2019, 19:01
Forum : Excel - VBA
Sujet : Effacer une cellule = réinitialiser une ligne
Réponses : 1
Vues : 38

Re: Effacer une cellule = réinitialiser une ligne

Bonjour toutes et tous
Je ne sais pas si, j'ai bien compris (merci à Ferrand :wink: )
- ajouter un bouton
1)sélectionner la ligne
2) clic bouton
les formules y sont ci-joint (dans le Module 2 Macro Ajouter)
crdlt,
André
par Andre13
20 mars 2019, 18:45
Forum : Excel - VBA
Sujet : Recherche avec sélection
Réponses : 3
Vues : 54

Re: Recherche avec sélection

Bonjour toutes et tous coucou Thev et merci :wink: @Airwols pour l'onglet 'Choix" de ton classeur formule en cellule B2 =RECHERCHEV($A2;BD!A:H;2;FAUX) C2: =RECHERCHEV($A2;BD!A:H;3;FAUX) D2: =RECHERCHEV($A2;BD!A:H;4;FAUX) E2: =RECHERCHEV($A2;BD!A:H;5;FAUX) F2: =RECHERCHEV($A2;BD!A:H;6;FAUX) G2: =RECH...
par Andre13
19 mars 2019, 20:05
Forum : Excel - VBA
Sujet : Validation aprés remplissage usf
Réponses : 7
Vues : 123

Re: Validation aprés remplissage usf

Bonjour toutes et tous: à tester pour ta textbox5 (Sécu.) Private Sub TextBox5_AfterUpdate() TextBox5.Value = Format(TextBox5.Value, "0"" ""00"" ""00"" ""00"" ""000"" ""000"" ""00") End Sub à tester pour la textbox5 (uniquement des chiffres de 0 à 9) (sécu) ' n autoriser que des chiffres alphanuméri...
par Andre13
15 mars 2019, 23:52
Forum : Excel - VBA
Sujet : Selection de cellules non contigues
Réponses : 3
Vues : 47

Re: Selection de cellules non contigues

Bonjour toutes et tous @Jeff59, si, j'ai bien compris, ci-joint Explication: Dans un module 'Module1 Option Explicit ' Déclaration variable Dim formule1, formule2 As String Sub test() ' la macro ' en cas d erreur On Error GoTo plouf ' la feuille1 With Sheets("feuil1") Range("d15").Select formule1 = ...
par Andre13
14 mars 2019, 18:30
Forum : Excel - VBA
Sujet : Transformer contenu d'une cellule en liste deroulante
Réponses : 7
Vues : 89

Re: Transformer contenu d'une cellule en liste deroulante

Bonjour toutes et tous
bout de code de Dan merci à lui ;;) + enregistreur de macro
ci-joint, on peut toujours l'améliorer :wink:


Note,
En cliquant le bouton 'GO' de la Feuil1, un mot dans la colonne B, le cellule voisine de droite une liste déroulante apparaîtra
André