18 résultats trouvés

par momowood
19 juillet 2017, 19:04
Forum : Excel - VBA
Sujet : Ne pas appliquer la formule si cases vides !
Réponses : 16
Vues : 414

Re: Ne pas appliquer la formule si cases vides !

Désolé Galopin, J'étais resté sur le 1 er fichier et donc la 1 ère formule que j'ai modifié avec ma petite connaissance :) Par contre ton fichier marche nickel et la formule parait simple . Mais je ne voie pas comment ca remplis ABPA et Non ABPA suivant les conditions . C'est trop fort pour moi. Tu ...
par momowood
19 juillet 2017, 18:50
Forum : Excel - VBA
Sujet : Macro pour remplir document
Réponses : 43
Vues : 1096

Re: Macro pour remplir document

Bonjour,

Dans ton fichier il y a aucune macro.
En gros tu veux remplir les cases vides dans la page Bon de palette et en cliquant sur un bouton que ça remplisse dans les cases correspondantes dans Stockage et que ça imprime 2 fois le bon de palettes ? c'est bien ça ?
par momowood
19 juillet 2017, 18:35
Forum : Excel - VBA
Sujet : Ne pas appliquer la formule si cases vides !
Réponses : 16
Vues : 414

Re: Ne pas appliquer la formule si cases vides !

Bonjour, Avec cette formule ça marche !! enfin si j'ai bien suivi :) =SI(ET(C15="positif";OU(ET(C16>=1000;OU(ET(C17="positif";OU(C20="oui";ET(C20="non";C21>=500)));ET(C17="négatif";C20="oui";C21>=500)));ET(C16<1000;C17="positif";C20="oui";C21>=500)));"ABPA";SI(C15="";"";SI(C16="";"";SI(C17="";"";SI(...
par momowood
14 avril 2017, 18:15
Forum : Excel - VBA
Sujet : userform au démarrage + cnum() excel 2013 ok 2007 pb
Réponses : 4
Vues : 197

Re: userform au démarrage + cnum() excel 2013 ok 2007 pb

Juste pour info Galopin01

Pour l'erreur 2 essayer en C3 remplacer par :
=SI(D3="";"";D3*1) puis tirer vers le bas...
cela ne fonctionnait pas

un grand merci quand même

Momowood
par momowood
14 avril 2017, 17:38
Forum : Excel - VBA
Sujet : userform au démarrage + cnum() excel 2013 ok 2007 pb
Réponses : 4
Vues : 197

Re: userform au démarrage + cnum() excel 2013 ok 2007 pb

Solution pour mon 2 ème problème trouvé.
il suffit juste, lorsque j'importe la saisie de TextBox5 de rajouter .Value soit TextBox5.value.
Et là tout fonctionne .

Joyeuse Pâques à tous.

Momowood
par momowood
14 avril 2017, 17:07
Forum : Excel - VBA
Sujet : userform au démarrage + cnum() excel 2013 ok 2007 pb
Réponses : 4
Vues : 197

Re: userform au démarrage + cnum() excel 2013 ok 2007 pb

Bonjour Galopin01, Nickel pour mon 1 er problème l'userform se lance au démarrage. Merci pour ta réponse très rapide. Pour mon 2 eme problème je me suis trompé sur sur cette phrase: l a formule de la cellule en C est un cnum() de la valeur texte en colonne F même ligne. En faite c'est: la formule de...
par momowood
14 avril 2017, 16:33
Forum : Excel - VBA
Sujet : userform au démarrage + cnum() excel 2013 ok 2007 pb
Réponses : 4
Vues : 197

userform au démarrage + cnum() excel 2013 ok 2007 pb

Bonjour à tous, J'ai 2 soucis sur mon fichier que j'ai créé pour mon Comité d'entreprise. Au travail j'utilise Excel 2013 aucun problème tout fonctionne. Chez moi j’utilise Excel 2007 et la ça ne va plus, je ne peux donc pas le terminer chez moi. 1 er problème au démarrage un userform se lance et j'...
par momowood
18 novembre 2016, 16:34
Forum : Excel - VBA
Sujet : renvoi des données
Réponses : 10
Vues : 205

Re: renvoi des données

Bonjour, Je ne sais pas pourquoi ce ne prends pas le mois en l'écrivant dans la formule. Mais ca marche comme ci-dessous. Pour la colonne mai. copie la formule de la colonne avril en g2 et colle la en h2 =RECHERCHEV(A2;avril!$A$1:$AB$65;27;FAUX) sélectionnes le avril! dans la formules avec le ! . Un...
par momowood
17 novembre 2016, 22:35
Forum : Excel - VBA
Sujet : renvoi des données
Réponses : 10
Vues : 205

Re: renvoi des données

Bonsoir,

Voici une proposition avec quelques changements dans les colonnes des mois.
par momowood
17 novembre 2016, 21:21
Forum : Excel - VBA
Sujet : RECHERCHER DES VALEURS
Réponses : 3
Vues : 132

Re: RECHERCHER DES VALEURS

Bonsoir,

J'ai pas mieux que ta formule avec les sierreur.
Elle fonctionne bien pour la recherche sur plusieurs onglets .