11093 résultats trouvés

par Steelson
il y a 56 minutes
Forum : Excel - VBA
Sujet : [VBA] Valeur max moitie de cellule
Réponses : 3
Vues : 13

Re: [VBA] Valeur max moitie de cellule

Function valmax(plage As Range) As String
valmax = ""
maxi = 0
For Each cel In plage
    valeur = Split(cel.Value & "-0", "-")(1) * 1
    If valeur > maxi Then
        maxi = valeur
        valmax = cel.Value
    End If
Next
End Function
par Steelson
Aujourd’hui, 04:34
Forum : Excel - VBA
Sujet : Comment faire une moyenne pondérée avec gestion des "NA"?
Réponses : 1
Vues : 16

Re: Comment faire une moyenne pondérée avec gestion des "NA"?

Bonjour,

moyenne de chaque colonne en matriciel
=SOMME(SI(ESTNA(A3:A9);0;A3:A9))/SOMME(SI(ESTNA(A3:A9);0;1))
ensuite moyenne générale pondérée
=SOMMEPROD(F3:I3*A1:D1)
par Steelson
Aujourd’hui, 04:25
Forum : Excel - VBA
Sujet : [VBA] Valeur max moitie de cellule
Réponses : 3
Vues : 13

Re: [VBA] Valeur max moitie de cellule

Bonjour,

sans VBA, en matriciel
=INDEX($A$1:$A$7;SOMME(SI(DROITE(A1:A7;3)*1=MAX(DROITE(A1:A7;3)*1);LIGNE($A$1:$A$7))))
par Steelson
Hier, 18:44
Forum : Excel - VBA
Sujet : Besoin d'aide pour optimiser le suivi de mes gardes de pompier
Réponses : 85
Vues : 1564

Re: Besoin d'aide pour optimiser le suivi de mes gardes de pompier

Après beaucoup d'atermoiement de ma part pour trouver une solution "flexible", voici une proposition
par Steelson
Hier, 11:15
Forum : Excel - VBA
Sujet : Somme.si.ens de dates courtes depuis un mois en lettre
Réponses : 2
Vues : 24

Re: Somme.si.ens de dates courtes depuis un mois en lettre

Bonjour
=SOMME((NOMPROPRE(TEXTE(Feuil3!$C$2:$C$8;"mmmm"))=Feuil1!$A$2)*(Feuil3!$A$2:$A$8=Feuil1!A4))
en matriciel (à valider par Ctrl+Maj+Entrée)

mais il faut que ta liste des mois soit accentuée !!

edit : U.Milité m'a grillé ...
j'ajoute qu'il faudrait aussi inclure l'année ??
par Steelson
18 juin 2019, 19:04
Forum : Excel - VBA
Sujet : Message d'erreur
Réponses : 1
Vues : 36

Re: Message d'erreur

Bonjour,

fais une table :
valeur de C | valeur de D | borne inf | borne sup | concaténation C&D

et ensuite fais un index/equiv sur C&D pour trouver les bornes adhoc
par Steelson
18 juin 2019, 13:35
Forum : Excel - VBA
Sujet : VBA : Macro qui part en vrille
Réponses : 12
Vues : 227

Re: VBA : Macro qui part en vrille

J'ai ajouté des sorties intermédiaires et fais un exit sub avant plantage, mais je ne sais pas interprêter les résultats sur les différentes feuilles. Et puis ensuite, cela ne plante pas toujours pour les mêmes valeurs de j (mais toujours quand k=2 -parce qu'avec k=1 il ne se passe rien-, et i=2) Je...
par Steelson
18 juin 2019, 13:09
Forum : Excel - VBA
Sujet : VBA : Macro qui part en vrille
Réponses : 12
Vues : 227

Re: VBA : Macro qui part en vrille

En terme de syntaxe, ceci m'a en effet troublé !! m = 0 With Sheets("Relevés") For i = 2 To .Range("B" & Rows.Count).End(xlUp).Row For j = 1 To 6 On Error Resume Next m = Application.WorksheetFunction.Match(.Range("B" & i), Cells(1, j).EntireColumn, 0) If m > 0 Then Cells(m, j).Cut Cells(Cells(Rows....
par Steelson
18 juin 2019, 06:04
Forum : Excel - VBA
Sujet : Macro recuperer donnée site web
Réponses : 14
Vues : 140

Re: Macro recuperer donnée site web

Voici ce que me répond une ligne dont les données sont absentes :
par Steelson
18 juin 2019, 05:59
Forum : Excel - VBA
Sujet : Macro recuperer donnée site web
Réponses : 14
Vues : 140

Re: Macro recuperer donnée site web

D'après les tests que j'avais commencé hier, je pense que le problème vient de la trop grande sollicitation du serveur.
Soit tu ajoutés un msgbox à chaque interrogation, soit tu le fais pas paquets de 10 par exemple.