2730 résultats trouvés

par R@chid
6 décembre 2019, 02:01
Forum : Excel - VBA
Sujet : Tenir compte du filtre avec formule Nb.Si.Ens
Réponses : 6
Vues : 122

Re: Tenir compte du filtre avec formule Nb.Si.Ens

Bonjour @ tous,
*ESTNUM(CHERCHE("/";Données!C2:C2001))


Cordialement
par R@chid
5 décembre 2019, 15:49
Forum : Excel - VBA
Sujet : Tenir compte du filtre avec formule Nb.Si.Ens
Réponses : 6
Vues : 122

Re: Tenir compte du filtre avec formule Nb.Si.Ens

Bonjour @ tous,
Oui bien-sûr on peut inclure deux critères de recherche voir plus.
=SOMMEPROD(SOUS.TOTAL()*(Plage1=Crit1)*(Plage2=Crit2)*...*(PlageN=CritN))

Cordialement
par R@chid
5 décembre 2019, 12:48
Forum : Excel - VBA
Sujet : Moyenne avec symbole
Réponses : 6
Vues : 135

Re: Moyenne avec symbole

Bonjour @ tous,
ça marche aussi avec la formule que je t'ai proposée :
=MOYENNE(CNUM(SUBSTITUE(C6:C8;"γ";)))
avec une validation matricielle en appuyant simultanément sur les 3 touches Ctrl+Shift+Enter


Cordialement
par R@chid
5 décembre 2019, 01:47
Forum : Excel - VBA
Sujet : Tenir compte du filtre avec formule Nb.Si.Ens
Réponses : 6
Vues : 122

Re: Tenir compte du filtre avec formule Nb.Si.Ens

Bonjour,
pour nombre de poste de rotation :
=SOMMEPROD(SOUS.TOTAL(3;DECALER(Données!K1;LIGNE(INDIRECT("1:"&LIGNES(Données!K2:K137)));))*(Données!K2:K137="Rotation"))

Cordialement
par R@chid
5 décembre 2019, 01:41
Forum : Excel - VBA
Sujet : RECHERCHEV à double inconnue
Réponses : 6
Vues : 85

Re: RECHERCHEV à double inconnue

Bonjour @ tous,
j'ai rien compris, en B2:
=SOMMEPROD((Feuil6!A$2:A$57=A2)*ESTNUM(CHERCHE("PCK-AN";Feuil6!J$2:J$57));Feuil6!K$2:K$57)
@ tirer vers le bas


Cordialement
par R@chid
5 décembre 2019, 01:32
Forum : Excel - VBA
Sujet : Moyenne avec symbole
Réponses : 6
Vues : 135

Re: Moyenne avec symbole

Bonjour
:bv:
selon ton exemple :
=MOYENNE(CNUM(SUBSTITUE(A1:A6;"*";)))
@ valider par Ctrl+Shift+Enter


Cordialement
par R@chid
3 décembre 2019, 16:53
Forum : Excel - VBA
Sujet : Copier valeurs sans vide avec formule et sans macro
Réponses : 3
Vues : 38

Re: Copier valeurs sans vide avec formule et sans macro

Bonjour, oui on peut faire cela par une formule matricielle, mais je peux te conseiller une autre astuce, tu peux toutefois appliquer un filtre sur la colonne C tout en masquant les cellules vides, puis : 2019-12-03_16-51-01.jpg 2019-12-03_16-51-35.jpg Et avec un copier/coller des valeurs sélectionn...
par R@chid
2 décembre 2019, 15:45
Forum : Excel - VBA
Sujet : Formule pour classer en fonction des familles de produits
Réponses : 3
Vues : 43

Re: Formule pour classer en fonction des familles de produits

Bonjour,
:bv:
en G4 :
=SOMME.SI(C$4:C$16;E4;B$4:B$16)
@ tirer vers le bas


Cordialement
par R@chid
2 décembre 2019, 13:09
Forum : Excel - VBA
Sujet : Automatisation calcul + Tableau
Réponses : 3
Vues : 98

Re: Automatisation calcul + Tableau

Bonjour,
tu peux juste le modifier dans la formule :
=SI(OU(I3=0;MAX(I$3:I3)=2);"";I$3*LIGNES($1:2))
Cordialement
par R@chid
1 décembre 2019, 22:16
Forum : Excel - VBA
Sujet : Recherche caractères numériques dans cellule
Réponses : 8
Vues : 73

Re: Recherche caractères numériques dans cellule

Re,
j'ai détaillé la formule en 4 pour que tu puisses comprendre.
Voir PJ
SHTOURS_Explication.xlsx
(9.87 Kio) Téléchargé 9 fois

Cordialement