245 résultats trouvés

par ouisansdoute
18 février 2019, 12:00
Forum : Excel - VBA
Sujet : Générer des codes barres EAN 128 dans excel
Réponses : 6
Vues : 72

Re: Générer des codes barres EAN 128 dans excel

Bonjour, J'ai eu besoin de la même chose il y a quelques années. J'ai récupéré le fichier joint réalisé par Thierry Pourtier d'après un code de GranZebu. Il faudra que tu installes la police code barre qui va bien par exemple : http://www.dafont.com/fr/code-128.font Je pense que cela pourra répondre...
par ouisansdoute
5 septembre 2018, 17:43
Forum : Excel - VBA
Sujet : total chiffre journalier jours de la semaine, probleme avec =SOMME.SI
Réponses : 7
Vues : 129

Re: total chiffre journalier jours de la semaine, probleme avec =SOMME.SI

L'avantage avec mferrand c'est qu'en plus il est très pédagogue. Respects.
par ouisansdoute
5 septembre 2018, 13:47
Forum : Excel - VBA
Sujet : total chiffre journalier jours de la semaine, probleme avec =SOMME.SI
Réponses : 7
Vues : 129

Re: total chiffre journalier jours de la semaine, probleme avec =SOMME.SI

Bonjour,

Tu peux le faire avec la fonction SOMMEPROD suivante :
=SOMMEPROD((JOURSEM(A2:A31)=2)*(B2:B31))

2 pour lundi
3 pour mardi
4 pour mercredi
etc.
par ouisansdoute
5 septembre 2018, 11:27
Forum : Excel - VBA
Sujet : Erreur recherchev
Réponses : 4
Vues : 47

Re: Erreur recherchev

Bonjour, Attention : la valeur recherchée doit être dans la première colonne du tableau de recherche. Je pense que l'erreur vient de là. Par ailleurs, si tu dois recopier la formule vers le bas, il serait plus correct soit de nommer le tableau de recherche, soit de le mentionner en références absolu...
par ouisansdoute
24 mai 2018, 20:37
Forum : Excel - VBA
Sujet : integrer une condition dans une condition
Réponses : 4
Vues : 203

Re: integrer une condition dans une condition

J'étais allée un peu trop vite et ne l'avais pas testée.
Tant mieux si ca vous a mis sur la bonne voie.
par ouisansdoute
24 mai 2018, 19:17
Forum : Excel - VBA
Sujet : Graphique avec 2 séries distinctes
Réponses : 1
Vues : 65

Re: Graphique avec 2 séries distinctes

Bonjour, Des pistes : Il est possible de représenter deux séries différentes sur un même graphique avec des échelles différentes. Pour cela on utilise l'axe des ade droite et on définit une échelle personnalisée pour la seconde série. Cependant il faut que ton paramètre temps soit la même référence ...
par ouisansdoute
24 mai 2018, 18:59
Forum : Excel - VBA
Sujet : Si date superieure
Réponses : 10
Vues : 172

Re: Si date superieure

Bonjour,

Pour la dernière colonne vous pouvez essayer la formule suivante :
=SI(A5="";"";SI(L5="OK"; " Prévoir enlèvement"; " Marchandise à isoler"))

En recopiant la formule sur tout le tableau. Cette cellule n'aura aucune valeur tant que la date de relevé d'anomalie ne sera pas saisie.
par ouisansdoute
24 mai 2018, 18:54
Forum : Excel - VBA
Sujet : integrer une condition dans une condition
Réponses : 4
Vues : 203

Re: integrer une condition dans une condition

Bonjour,

Dans le fichier joint il n'y a rien en colonne B.

Une proposition cependant :
SI(B34<B40;1177-(B40*0,75)<=0;"0";1177-(B40*0,75);1177-(B34*0,75)<=0;"0";1177-(B34*0,75))
par ouisansdoute
24 mai 2018, 18:45
Forum : Excel - VBA
Sujet : Filtrer et copier une partie de texte dans une cellule
Réponses : 7
Vues : 130

Re: Filtrer et copier une partie de texte dans une cellule

Bonjour, Si chaque cellule contient " TEL" en première position et "MAIL" en seconde, la formule peut être la suivante : =SI(ET(CHERCHE(" TEL";A1;1)>0;CHERCHE(" MAIL";A1;1)>0;CHERCHE(" MAIL";A1;1)>CHERCHE(" TEL";A1;1));STXT(A1;CHERCHE(" TEL";A1;1);CHERCHE(" Mail";A1;1)-CHERCHE(" Tel";A1;1));"XXX") S...
par ouisansdoute
23 mai 2018, 13:52
Forum : Excel - VBA
Sujet : Filtrer et copier une partie de texte dans une cellule
Réponses : 7
Vues : 130

Re: Filtrer et copier une partie de texte dans une cellule

Bonjour,

Une piste :
ApparemmentOn peut repérer les numéros de téléphone par les caractères ' TEL', voici donc une proposition de formule pour extraire les numéros de téléphone :
=SI(CHERCHE(" TEL";A1;1)>0; STXT(A1;CHERCHE(" TEL";A1;1)+1;50);"Tél non trouvé")