r

Membre habitué

Inscrit le :05/04/2016
Dernière activité :10/12/2019 à 10:00
Version d'Excel :2010
Messages
139
Votes
5
Fichiers
0
Téléchargements
0

Sujets créés par romainromain

DateForumSujetExtrait du message
10/12/2019 à 00:00CalcFonction SI avec COULEUREst-il possible de faire une fonction si avec une couleur je m'explique : J'ai des valeurs du genre : 34 / 31 / 56 / 12 J'aimerais que le chiffre qui suit est un fond Rouge ou Vert selon le fait que le chiffre avant soit plus grand (donc la couleur serait rouge) ou que le chiffre soit plus petit (da...
11/05/2016 à 11:13Excel - VBAEnregistrement d'un classeur Excel VBAHier grâce à votre aide j'ai réussi à copier deux onglets d'un fichier principal pour les mettre dans un nouveau classeur. Ca marche parfaitement ! Maintenant il faudrait que j'arrive à enregistrer ce classeur en y ajoutant un nom et en revenant ensuite sur la feuille principale : ] Merci beauco...
10/05/2016 à 10:41Excel - VBA Probleme de code sheets.CopyJ'ai un souci avec le code suivant : J'aimerais pouvoir Cpoier deux feuilles mais je ne sais pas comment et le and ne marche absolument pas mais je voulais tester des trucs.. Merci...
09/05/2016 à 10:29Excel - VBACréation d'un fichier de deux ongletsVoici mon petit souci, je souhaite créer un fichier Excel de deux onglets qui se trouvent dans un classeur beaucoup plus grand. Le problème c'est que les deux feuilles qui doivent se mettre ensemble pour la création du fichier ne porte pas le même nom (forcement). De plus j'ai ce code qui me permet...
18/04/2016 à 15:40Excel - VBA Couleurs dans une conditionEst-il possible de mettre une couleur dans une condition. Je m'explique : J'ai dans la colonne G des noms de cabinets (cabinet1, cabinet2, cabinet3,...) à partir de la 7ème ligne et dans la colonne S rien du tout hormis le fait que la couleur peut être soit blanche (la couleur normal d'excel) soit d...
14/04/2016 à 12:09Excel - VBA Création de feuille avec conditionsDans le fichier ci-joint il y a une liste de nom de fruits, les premiers en blancs et les seconds en jaune. J'aimerais pouvoir créer des nouveaux onglets avec le nom des fruits si et seulement si ils possèdent au moins une lignes jaunes et sinon ne pas en créer. Et dans ce nouvel onglet y mettre les...
14/04/2016 à 10:15Excel - VBA Appler une variable d'une autre macroBonjour à tous, J'ai créé plusieurs macros et je souhaiterais savoir si il était possible de récupérer une variable dans une macro réaliser précédemment, du style : Est-il possible de faire cela ? (En ajoutant une partie de code bien sûr parce que là ça n'a aucune chance de fonctionner) Cordialement...
13/04/2016 à 16:28Excel - VBASi et OUEst-il possible de faire une condition si de la façon suivante : =SI(OU(H358="Plutôt pas d'accord";H358="Pas du tout d'accord";I358="Plutôt pas d'accord";I358="Pas du tout d'accord";J358="Plutôt pas d'accord";J358="Pas du tout d'accord");1;" " Enfaite, la possibilité de faire un OU sur la même cellu...
12/04/2016 à 14:13Excel - VBAAddition videVoici mon petit souci : Je dois faire l'addition de deux cellules par exemple A1+A10, jusqu'ici tout va bien. Ensuite lorsque je déroule mon calcul pour les lignes du dessous j'ai des #VALEURS! qui apparaissent parce que les cellules en questions sont vides, est-il possible de faire une sorte de som...
12/04/2016 à 09:33Excel - VBA Parcourir une colonne pour remplir les cellules videsJe cherche à parcourir la colonne X à partir de la lignes 340 jusqu'à la lignes 357, en mettant dans les cellules vides une condition. Cependant je ne trouve pas le moyen de faire cela. Bien à vous, romain...
11/04/2016 à 16:53Excel - VBA Retirer des chiffresAlors voici mon souci : Je souhaite récupérer (par exemple) le code AA dans la chaine de caractère suivante : 2016AA00123456 Mais je veux aussi récupérer le code DE si le code est du typer 2016DE00124578 Les chiffres ne sont jamais les même et les codes non plus, il y a t'il une formule excel pour c...
11/04/2016 à 15:54Excel - VBA Different de dans une conditionLà où il y a "<> TOTO", je veux dire que si P348 est différent de TOTO alors rien et sinon P348 (Si la condition W348="PT" est valable bien sur) J'ai eu l'idée du "<>" car on l'utilise dans les somme.si() =SI(ET(W348="PT";P348="<> TOTO");" ";P348) Je sais pas si j'ai bien expliqué...
11/04/2016 à 10:49Excel - VBA Selection de feuille via le nomJe souhaite faire une condition, en demandant : Si la feuille du nom de "toto" existe alors la supprimer sinon rien faire j'ai fait ce code qui ne fonctionne pas : Cordialement...
07/04/2016 à 11:55Excel - VBAPouvoir annuler une macro en appuyant sur annulerBonjour, voici mon problème : Dans ma macro à plusieurs moments je demande d'inscrire dans une Application.Inputbox(...) une date ou un nombre, sauf que si je me trompe ou si je veux annuler, la macro continue puisque je n'ai pas fait les conditions, pouvez-vous me montrer à quoi elles devraient res...
06/04/2016 à 10:38Excel - VBA Valeur inscrite par l'utilisateurJe voudrais afficher une msgbox (ou dans le style) qui permettrait d'entrer une valeur dans un champ et qui prendrait par la suite la place dune variable. Par exemple : Désolé si ce n'est pas très clair Cordialement, romain...
05/04/2016 à 14:08Excel - VBA Paser automatiquement à la macro qui suitExiste t'il un bon de macro qui permet de passer de la première à la seconde macro automatiquement sans intervention de l'utilisateur ? J'ai le cas avec deux macros que je voudrais exécuter à la suite mais sans les mettre l'une dans l'autre. Ma première macro est Macro1 et la seconde Macro2. Cordial...
05/04/2016 à 12:49Excel - VBA Supprimer une feuille Excel qui ne comporte une seule ligneVoici mon souci, je dois créer des feuilles Excel et parmi celles-ci se trouvent des feuilles qui ne comportent seulement une seule ligne. Est-il possible via un code VBA de supprimer les feuilles qui ne possèdent qu'une seule ligne ? (En l'occurrence la ligne se situerait sur la 3ème ligne) Cordial...